WebMO - Computational chemistry on the WWW
Recent news

WebMO 19.0 is now available for free download!

WebMO 19.0 Pro and Enterprise have a variety of additional features and is available for purchase.

The WebMO app is now available for iOS and Android.

Cannot reset admin password Log Out | Topics | Search
Moderators | Edit Profile

WebMO Support Forum » WebMO Installation » Initial Configuration of WebMO » Cannot reset admin password « Previous Next »

Author Message
Anatole Sarko
Posted on Wednesday, January 22, 2003 - 12:34 pm:   

I have installed WebMO.3.3.002 on a laptop (running SuSE 7.2) that resides behind a firewall and does not possess a fully qualified DNS address. Apache is running on 'localhost'. WebMO installed OK, and I can log in with 'admin' and a blank password. However, the submit on the reset admin password hangs and I cannot go beyond this point. The permissions on all relevant directories are set to 777. I attach the output from running 'perl diagnose.pl'. Any help will be appreciated.
Anatole Sarko

WebMO Diagnostic Output
The following information can be used to diagnose WebMO configuration problems.
Any failures will be marked in red.

System InformationLinux asarko1 2.4.4-4GB #1 Fri May 18 14:11:12 GMT 2001 i686 unknown

Checking Home DirectoryChecking home directory: Warning
Home directory must be world-executable if WebMO is installed there

Checking CGI DirectoryChecking /usr/local/httpd/cgi-bin/webmo: Passed
Checking /usr/local/httpd/cgi-bin/webmo/login.cgi: Passed
Checking /usr/local/httpd/cgi-bin/webmo/interfaces: Passed
Checking /usr/local/httpd/cgi-bin/webmo/interfaces/globals.int: Passed

Checking User DirectoryChecking /usr/local/webmo: Passed
Checking /usr/local/webmo/jobs: Passed
Checking /usr/local/webmo/users: Passed
Checking /usr/local/webmo/queue: Passed
Checking /usr/local/webmo/errors: Passed

Checking Scratch DirectoryChecking /tmp/webmo: Passed

Checking Apache ConfigurationChecking for AddHandler cgi-scripts enabled: Passed
Checking for UserDir enabled: Passed
Checking for suExec enabled: Enabled
Apache is running as user wwwrun
Document root directory is /usr/local/httpd/htdocs
Document root directory is /usr/local/httpd/htdocs

WebMO Configuration FilebackgroundGraphic="background_dna.gif"
catPath="/bin/cat"
cgiBase="/usr/local/httpd/cgi-bin/webmo"
cpPath="/bin/cp"
host="localhost"
htmlBase="/usr/local/httpd/htdocs/webmo"
killPath="/bin/kill"
license="0205-0701-4687"
mkdirPath="/bin/mkdir"
mvPath="/bin/mv"
owner="Computational Chemistry on the WWW"
perlPath="/usr/bin/perl"
psOptions="-ef"
psPath="/bin/ps"
psRegExp="(\$pid, \$ppid, \$cpu_time) = /.{6}(.{8})(.{6}).{3}.{6}.{6}(.{12}).*/"
rcpPath="/usr/bin/rcp"
rmPath="/bin/rm"
rshPath="/usr/bin/rsh"
scpOptions="-o Protocol=1"
scpPath="/usr/bin/scp"
sendmailOptions="-t"
sendmailPath="/usr/sbin/sendmail"
servers="localhost,0"
sshOptions="-o Protocol=1"
sshPath="/usr/bin/ssh"
systemScratch="/tmp"
tableBackgroundColor="#99cccc"
tarOptions="cf"
tarPath="/bin/tar"
unamePath="/bin/uname"
url_cgiBase="/cgi-bin/webmo"
url_htmlBase="/webmo"
userBase="/usr/local/webmo"
version="3.3.002"
webserver="localhost"
whereisPath="/usr/bin/whereis"
schmidt
Posted on Wednesday, January 22, 2003 - 1:16 pm:   

The password should be reset, even though the page may appear to hang. Just go back to the login screen and login as admin, with the new administrative password.

The fact that you entered only localhost as your hostname should not give you any problems. That statement was in there because of a technical detail, where having the short form of a hostname gave problems when running GAMESS.
Anatole Sarko
Posted on Wednesday, January 22, 2003 - 2:34 pm:   

Thank you for your reply.
No, a new password is not accepted, as a subsequent attempt to login fails. A login with a blank password is accepted but brings up the reset password screen again - a vicious circle.
Anatole Sarko
schmidt
Posted on Thursday, January 23, 2003 - 3:58 pm:   

Check to make sure JavaScript is enabled in your browser. (Solved problem)
Rob F
Unregistered guest
Posted on Thursday, February 26, 2009 - 4:59 pm:   

I'm observing the same issue in a new installation. Javascript is enabled. Tried several browser variations - Safari 3.1.2 and Firefox 2.0.0.14 on the Mac (OS 10.4) and Firefox 2.0.0.18 and IE 6 under Windows XP. The diagnose.html for the installation follows:

System Information

Checking Home Directory

Checking home directory: Passed

Checking CGI Directory
Checking /home/chem/public_html/cgi-bin: Passed( 2755, fullmer )
Checking /home/chem/public_html/cgi-bin/login.cgi: Passed( 0755, fullmer )
Checking
/home/chem/public_html/cgi-bin/interfaces: Passed( 2777, fullmer )
Checking /home/chem/public_html/cgi-bin/interfaces/globals.int: Passed( 0777, fullmer )

Checking User Directory
Checking /home/chem/webmo: Passed( 0777, fullmer )
Checking /home/chem/webmo/jobs.db: Passed( 0777, fullmer )
Checking /home/chem/webmo/users.db: Passed( 0777, fullmer )
Checking /home/chem/webmo/queue: Passed( 0777, fullmer )
Checking /home/chem/webmo/errors: Passed( 0777, fullmer )

WebMO Configuration File
catPath="/usr/local/bin/cat"
cgiBase="/home/chem/public_html/cgi-bin"
chmodPath="/usr/local/bin/chmod"
chownPath="/usr/local/bin/chown"
cpOptions="-r"
cpPath="/usr/local/bin/cp"
externalAuthentication=""
externalBatchQueue=""
host="www.chem.pdx.edu"
htmlBase="/home/chem/public_html/webmo"
killPath="/usr/local/bin/kill"
license="0902-2004-7903"
loginMsg=""
loginMsgTimestamp=""
mkdirPath="/usr/local/bin/mkdir"
mvPath="/usr/local/bin/mv"
ncores="1"
owner="Computational Chemistry on the WWW"
perlPath="/usr/local/bin/perl"
psOptions="-ef"
psPath="/bin/ps"
psRegExp="(\$pid, \$ppid, \$cpu_time) = /.{8}(.{6})(.{6}).{4}.{9}.{8}(.{9}).*/"
rcpPath="/bin/rcp"
rmOptions="-rf"
rmPath="/usr/local/bin/rm"
rshPath="/bin/rsh"
scpOptions=""
scpPath="/usr/local/bin/scp"
sendmailOptions="-t"
sendmailPath="/usr/sbin/sendmail"
servers="www.chem.pdx.edu,0"
sshOptions=""
sshPath="/usr/local/bin/ssh"
sudoEnabled=""
sudoPath="/usr/local/bin/sudo"
systemScratch="/tmp"
tarOptions="cf"
tarPath="/usr/local/bin/tar"
unamePath="/bin/uname"
uniqueId="28781"
unzipPath="/usr/local/bin/unzip"
url_cgiBase="/cgi-bin"
url_htmlBase="/webmo"
userBase="/home/chem/webmo"
userStorageEnabled=""
version="9.1.002"
webserver="autodetect"
webserverProtocol="autodetect"
whereisPath="/usr/local/bin/which"
zipOptions="-r -q"
zipPath="/usr/local/bin/zip"

Add Your Message Here
Post:
Username: Posting Information:
This is a public posting area. Enter your username and password if you have an account. Otherwise, enter your full name as your username and leave the password blank. Your e-mail address is optional.
Password:
E-mail:
Options: Post as "Anonymous"
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Last Week | Tree View | Search | Help/Instructions | Program Credits Administration