WebMO - Computational chemistry on the WWW
Recent news

WebMO 19.0 is now available for free download!

WebMO 19.0 Pro and Enterprise have a variety of additional features and is available for purchase.

The WebMO app is now available for iOS and Android.

April 7, 2020

Script window automatically closes af... Log Out | Topics | Search
Moderators | Edit Profile

WebMO Support Forum » WebMO Installation » Running the WebMO Setup Script » Script window automatically closes after pressing Enter at start « Previous Next »

Author Message
Alan Gu
Unregistered guest
Posted on Saturday, October 19, 2019 - 3:57 am:   

After running the setup.pl script in the unzipped WebMo installation package, a new window pops up with the following prompt:


WELCOME TO WEBMO VERSION 19.0.009 SETUP

In this portion of setup, you will be asked a few simple
questions about file locations. The WebMO files will then
be copied onto this server. After this is done you will log
into WebMO to finish configuration.
Enter to continue


However upon pressing Enter, the window closes immediately. The system is Windows 10 with ActivePerl 5.28 64-bit version, Apache 2.4.x OpenSSL 1.1.1 VC15 64-bit version, and GAMESS (https://www.msg.chem.iastate.edu/gamess/windows.html) installed as per the WebMO installation instructions. Running other perl scripts appear to have no problems, and perl is added to path. Anyone has clue on where the problem could be and how to solve it?

Much thanks.
JR Schmidt
Moderator
Username: Schmidt

Post Number: 656
Registered: 11-2006
Posted on Monday, October 21, 2019 - 11:14 am:   

There were some recent changes in the Perl distribution (Active State Perl) for Windows. The following older version should work fine for now:

https://downloads.activestate.com/ActivePerl/releases/5.26.3.2603/
Alan Gu
Unregistered guest
Posted on Monday, October 21, 2019 - 10:28 pm:   

Thank you JR.

However after installing the 5.26.3 version of ActivePerl and verified by 'perl -v' command, the installation window still automatically closes after pressing Enter, the same way as before.

Sorry this didn't work.
JR Schmidt
Moderator
Username: Schmidt

Post Number: 658
Registered: 11-2006
Posted on Tuesday, October 22, 2019 - 11:35 am:   

Did you the version specifically from the link above? Note that there are TWO builds of 5.26 available: a "legacy" version (linked above) and a "current" version (from the main website).

ActiveState has removed substantial library support form the current builds, which is causing problems. Use the link. It works for me!
Alan Gu
Unregistered guest
Posted on Tuesday, October 22, 2019 - 3:12 pm:   

Worked like a charm. Thank you JR.

For others reading this post, the correct download links are at the bottom of the page labelled 'Other Downloads', not the big blue buttons at the top.

Add Your Message Here
Post:
Username: Posting Information:
This is a public posting area. Enter your username and password if you have an account. Otherwise, enter your full name as your username and leave the password blank. Your e-mail address is optional.
Password:
E-mail:
Options: Post as "Anonymous"
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Last Week | Tree View | Search | Help/Instructions | Program Credits Administration