WebMO - Computational chemistry on the WWW
Recent news

WebMO 12.0 is now available for free download!

WebMO 12.0 Pro and Enterprise have a variety of additional features and is available for purchase.

WebMO can now be installed on Windows, Mac, and Unix servers!

August 24, 2019

Perl compatibility Log Out | Topics | Search
Moderators | Edit Profile

WebMO Support Forum » WebMO Installation » Other » Perl compatibility « Previous Next »

Author Message
Jack Smith
Unregistered guest
Posted on Friday, January 27, 2012 - 2:03 pm:   

We have version 10.1 version of WebMO (Enterprise), and we just upgraded our cluster OS, which includes a later version of Perl (5.10), and now the login.cgi script fails with "Can't call method "param" on an undefined value at parse.cgi line 24". I noticed that WebMO 12.0 now has "support for most recent versions of Perl". Does this mean that we have to upgrade our version of WebMO?
JR Schmidt
Moderator
Username: Schmidt

Post Number: 222
Registered: 11-2006
Posted on Friday, January 27, 2012 - 2:13 pm:   

You can either upgrade WebMO -- or downgrade (or install a second version) of Perl. The latter should not be hard to do.

This is happened because Perl 5.10 deprecated some features that we were using, and so I had to work around this (quite a task) in the new version.

Add Your Message Here
Post:
Username: Posting Information:
This is a public posting area. Enter your username and password if you have an account. Otherwise, enter your full name as your username and leave the password blank. Your e-mail address is optional.
Password:
E-mail:
Options: Post as "Anonymous"
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Last Week | Tree View | Search | Help/Instructions | Program Credits Administration