WebMO - Computational chemistry on the WWW
Recent news

WebMO 16.0 is now available for free download!

WebMO 16.0 Pro and Enterprise have a variety of additional features and is available for purchase.

The WebMO app is now available for iOS and Android.

August 17, 2019

MO Viewer on Mac Log Out | Topics | Search
Moderators | Edit Profile

WebMO Support Forum » WebMO Installation » Initial Configuration of WebMO » MO Viewer on Mac « Previous Next »

Author Message
Josh Layfield
Unregistered guest
Posted on Tuesday, January 26, 2016 - 3:26 pm:   

I have successfully installed WebMO on my linux machine and I can view MO's using the MO Viewer. When I try to change any of the preferences the Java Applet hangs. The preferences window works just fine on my windows laptop. These errors are reproducible on the WebMO test server.
I have made the recommended changes regarding the maximum heap size up to 1024 MB. I have updated my version of Java and firefox(and safari).
As a test, I notice that the memory used by the applet increases by about 100 MB when I open the preferences window. When I click on the isovalue box is when the window hangs.

Any help would be greatly appreciated!
JR Schmidt
Moderator
Username: Schmidt

Post Number: 490
Registered: 11-2006
Posted on Tuesday, January 26, 2016 - 3:28 pm:   

This sounds like a Java implementation bug. There are several implementations of Java available on Linux. Which one are you using?
Josh Layfield
Unregistered guest
Posted on Tuesday, January 26, 2016 - 4:01 pm:   

I use the standard Rocks 6.11 implementation.

java -version returns:

java version "1.7.0_51"
Java(TM) SE Runtime Environment (build. 1.7.0_51-b13)
Java HotSpot(TM) 64-bit Server VM (build 24.51-b03, mixed mode)
JR Schmidt
Moderator
Username: Schmidt

Post Number: 491
Registered: 11-2006
Posted on Tuesday, January 26, 2016 - 5:03 pm:   

Sorry, I was confused. You are accessing WebMO from a Mac (it sounds like). The version of Java on your Linux machine is irrelevant.

I just tried this on a fully up-to-date Mac (I believe) without any problems. Have you tried another machine just to verify?

Add Your Message Here
Post:
Username: Posting Information:
This is a public posting area. Enter your username and password if you have an account. Otherwise, enter your full name as your username and leave the password blank. Your e-mail address is optional.
Password:
E-mail:
Options: Post as "Anonymous"
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Last Week | Tree View | Search | Help/Instructions | Program Credits Administration