WebMO - Computational chemistry on the WWW
Recent news

WebMO 16.0 is now available for free download!

WebMO 16.0 Pro and Enterprise have a variety of additional features and is available for purchase.

The WebMO app is now available for iOS and Android.

August 23, 2019

WebMO Demo Job Manager screen is miss... Log Out | Topics | Search
Moderators | Edit Profile

WebMO Support Forum » Running WebMO Jobs » Job Manager » WebMO Demo Job Manager screen is missing buttons « Previous Next »

Author Message
meister
Unregistered guest
Posted on Wednesday, September 08, 2010 - 3:55 pm:   

The buttons that should be at the top of the screen in the Job Manager (New Job, Refresh, Download ...) are missing and the frames are screwed up. I tried two machines, three browsers under both OSX and Windows.
JR Schmidt
Moderator
Username: Schmidt

Post Number: 159
Registered: 11-2006
Posted on Wednesday, September 08, 2010 - 4:07 pm:   

Thanks for the heads up. The issue is now resolved.
Anonymous
 
Posted on Saturday, July 19, 2014 - 11:47 am:   

I just installed WebMO Pro. The buttons that should be at the top of the screen in the Job Manager (New Job, Refresh, Download ...) are missing and the frames are screwed up. I can not use the builder to get started.
JR Schmidt
Moderator
Username: Schmidt

Post Number: 406
Registered: 11-2006
Posted on Saturday, July 19, 2014 - 2:51 pm:   

This is almost certainly due to incorrect specifying the URL to the WebMO HTML files during installations. Two possible solutions are:

1) Location the webmo configuration files, globals.int, in the <webmo_cgi>/interfaces directory and modifying the url_htmlBase appropriately.

or

2) Doing a re-install, carefully checking the HTML and CGI URLs that are specified.
Chris Earnshaw
Unregistered guest
Posted on Tuesday, April 12, 2016 - 9:21 am:   

This issue seems to have cropped up again. I've just upgraded from WebMO 14 to 16 and the buttons at the top of the screen have vanished in Internet Explorer. They're present in Firefox, but that's not our company standard browser unfortunately. It would be helpful if IE were supported.
JR Schmidt
Moderator
Username: Schmidt

Post Number: 501
Registered: 11-2006
Posted on Tuesday, April 12, 2016 - 10:46 am:   

Dear Chris,

I just verified that I can see the buttons fine in the most recent version of IE (at least in Windows 7). Can you please see if the problem persists when accessing our Demo Server?

If the demo server works, your IE may have simply cached some outdated Javascript or an incorrect configuration of WebMO.
Chris Earnshaw
Unregistered guest
Posted on Tuesday, April 19, 2016 - 4:14 am:   

Hi

I've tried the demo server and that works fine with our IE11.0.9600.18230 browsers on Win7 Enterprise. However, we still don't see the buttons when connecting to our local WebMO server using IE11 even after clearing all cached browser data or using a PC which never connected to the previous version. The local server works fine with the same PCs using Firefox or Chrome.

Checking with the F12 console, I see that we get a script error warning:
SCRIPT1028:Expected identifier, string or number
File jobmgr_menu.js, Line: 66, Column: 9

which appears to relate to the comma before the closing brace in -
"logout": {name: "Logout", callback: function(key,opt){ Logout(document.form); return true;}},
}

Removing this comma and refreshing gets the buttons back, so it does appear to be a bug as far as our version of IE11 is concerned.

Apologies for the delayed reply - I only work with this client a couple of days a week.
JR Schmidt
Moderator
Username: Schmidt

Post Number: 502
Registered: 11-2006
Posted on Tuesday, April 19, 2016 - 10:14 am:   

Chris,

I believe you are correct. There is an extra comma. Oddly, I cannot reproduce the symptoms of the error on my own (seemingly identical setup). But I have removed the extraneous comma for the next release.

Add Your Message Here
Post:
Username: Posting Information:
This is a public posting area. Enter your username and password if you have an account. Otherwise, enter your full name as your username and leave the password blank. Your e-mail address is optional.
Password:
E-mail:
Options: Post as "Anonymous"
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Last Week | Tree View | Search | Help/Instructions | Program Credits Administration