WebMO - Computational chemistry on the WWW
Recent news

WebMO 17.0 is now available for free download!

WebMO 17.0 Pro and Enterprise have a variety of additional features and is available for purchase.

The WebMO app is now available for iOS and Android.

May 25, 2019

MOs not displaying Log Out | Topics | Search
Moderators | Edit Profile

WebMO Support Forum » Running WebMO Jobs » View Molecular Orbitals » MOs not displaying « Previous Next »

Author Message
Dan Berger
Unregistered guest
Posted on Wednesday, August 10, 2016 - 1:09 pm:   

I am using Firefox 46.0.1 and Java V8 101 build 1.8.0_101-b13.

I am running GAMESS and MOPAC 2016 under WebMO. The MO jobs are running fine, but when I click the "magnifying glass" to select and display an MO, nothing happens. When I click the "MO" display tab, it tells me to select an MO.
Dan Berger
Unregistered guest
Posted on Wednesday, August 10, 2016 - 1:14 pm:   

By the way, I turned off the popup blocker as well. This is under Windows 10.

I will try the guest server at webmo.net and report how that works.
Dan Berger
Unregistered guest
Posted on Wednesday, August 10, 2016 - 1:17 pm:   

OK, I tried it on the guest server (job names are "ethene").

MOPAC orbital display works fine.

GAMESS orbital display works for 6-31G but not for PM3; I had the same issue with my own server. But on my own server, the orbitals would calculate but not display.
JR Schmidt
Moderator
Username: Schmidt

Post Number: 515
Registered: 11-2006
Posted on Wednesday, August 10, 2016 - 1:48 pm:   

Check the Java Console (from Java in system tray) or Javascript Console (from browser) for any errors. This is usually caused by running over HTTPS using a certificate that Java / Oracle considers invalid.
Dan Berger
Unregistered guest
Posted on Wednesday, August 10, 2016 - 2:01 pm:   

I get this error message from the JS console:

TypeError: document.MOViewerApplet.open is not a function

doViewMolecularOrbital() view_job.js:356
ViewMolecularOrbital() jobmgr.cgi:446
<anonymous> :1
Dan Berger
Unregistered guest
Posted on Wednesday, August 10, 2016 - 2:02 pm:   

No errors showing in the Java console.
JR Schmidt
Moderator
Username: Schmidt

Post Number: 516
Registered: 11-2006
Posted on Wednesday, August 10, 2016 - 2:06 pm:   

Post the contents of your Java Console. It will indicate whether the MO Viewer applet even loaded.
Dan Berger
Unregistered guest
Posted on Wednesday, August 10, 2016 - 2:13 pm:   

Ah, yes. The Java Console is not showing anything at all beyond the admin stuff from when it opened:

Principal Axes are non-degenerate


--- NO ELEMENTS FOUND! ---


+ POINT GROUP FOUND:

{ E }

***************************
1. C1: 0.0
***************************


That's in spite of the fact that the viewer is showing the structure just fine. See the attached screenshot.Molecule viewer screenshot
Dan Berger
Unregistered guest
Posted on Wednesday, August 10, 2016 - 2:24 pm:   

I tried a coordinate scan using MOPAC, and it works fine. But I also notice that it runs entirely in Javascript; no applets involved.

I get the same "NO ELEMENTS FOUND" message in the Java console when I open that page.
Randy Miller
Unregistered guest
Posted on Tuesday, September 27, 2016 - 11:51 pm:   

I recently installed WebMO 17 on a Google Cloud Platform instance described in the "Support and Tutorials" section (with some modifications to the install scripts). I am able to build molecules using MOPAC7 and use all features that are not dependent on Java Applets. I am unable to view MOes. Thinking this might be due to improperly configured Java on my browsers (Firefox and Chrome) I tried to view MOes from the "Working Demo" on the WebMO site - these MOes were visualized just fine. What is wrong with my configuration on the Google Cloud Platform?

Add Your Message Here
Post:
Username: Posting Information:
This is a public posting area. Enter your username and password if you have an account. Otherwise, enter your full name as your username and leave the password blank. Your e-mail address is optional.
Password:
E-mail:
Options: Post as "Anonymous"
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Last Week | Tree View | Search | Help/Instructions | Program Credits Administration