WebMO - Computational chemistry on the WWW
Recent news

WebMO 19.0 is now available for free download!

WebMO 19.0 Pro and Enterprise have a variety of additional features and is available for purchase.

The WebMO app is now available for iOS and Android.

August 23, 2019

Adding many users... Log Out | Topics | Search
Moderators | Edit Profile

WebMO Support Forum » Administering WebMO » User Manager » Adding many users... « Previous Next »

Author Message
Anonymous
Posted on Friday, April 20, 2001 - 9:55 pm:   

Hello,

Great stuff, this WebMO! I was wondering if there is any way to add many users at once. If not, are there plans to allow webmo to slurp in a delimited text file of usernames and passwords? Sure would be nice when adding a class full of students.
schmidt
Posted on Saturday, April 21, 2001 - 11:27 am:   

That is a wonderful idea, and we will consider it for a future release!
Anonymous
 
Posted on Friday, November 20, 2009 - 1:02 pm:   

I just installed but I do not see how you obtain the admin password to get started.
JR Schmidt
Moderator
Username: Schmidt

Post Number: 127
Registered: 11-2006
Posted on Friday, November 20, 2009 - 1:08 pm:   

The default username is 'admin' and the password is blank (nothing). This is also given in the setup instructions.
Steven Boring
Unregistered guest
Posted on Thursday, June 13, 2013 - 7:12 pm:   

I have version 13.1.001 free version installed and see in the online help that the import users feature has been added but I don't see the feature available on the free version. Which version (pro or enterprise) has this feature?
JR Schmidt
Moderator
Username: Schmidt

Post Number: 356
Registered: 11-2006
Posted on Thursday, June 13, 2013 - 10:04 pm:   

Importing users from a spreadsheet, etc. is a Pro feature. WebMO Enterprise also adds the ability to integrate with LDAP, etc. enable centralized authentication.
rameshmaragani
Unregistered guest
Posted on Friday, April 11, 2014 - 10:30 am:   

iam a Ph.D student in IIT Indore in india, i want User name and password of webmo login version 13.1.001e,
JR Schmidt
Moderator
Username: Schmidt

Post Number: 393
Registered: 11-2006
Posted on Friday, April 11, 2014 - 12:45 pm:   

You need to email your local WebMO administrator.
Kathy Durkin
Unregistered guest
Posted on Thursday, June 05, 2014 - 6:11 pm:   

Could I see an example file format for importing users? I have tried a few comma and tab delimited txt and csv files and keep getting an error.

Here's an example I tried:
Username, Group, Password, FullName
user1, webmo, example-pw, Chem 265
JR Schmidt
Moderator
Username: Schmidt

Post Number: 401
Registered: 11-2006
Posted on Monday, June 09, 2014 - 2:01 pm:   

Kathy,

CSV files do not have comma and spaces as a delimeter, but rather ONLY commas. Use excel and save as a CSV file for easiest results.
Robert Badger
Unregistered guest
Posted on Wednesday, July 29, 2015 - 5:34 pm:   

Assuming one is successful in adding a full class of students fall semester, how does one remove all those users at the end of the semester. It would be nice if a text file could be used for the deletion process.
JR Schmidt
Moderator
Username: Schmidt

Post Number: 471
Registered: 11-2006
Posted on Tuesday, August 18, 2015 - 2:35 pm:   

FYI, I added this feature in WebMO 16.
Matthias Lein
Unregistered guest
Posted on Monday, July 11, 2016 - 11:29 pm:   

Hi there

Yesterday I was able to add a whole batch of users with a csv file. Today, I realised that I had mislabelled a column: The "Email" column header was on top of the wrong column so none of the users had an email address in their account. So, I proceeded to select all users of that group, deleted them and tried to re-import them with the correct csv file. Only this time I can't seem to add any users at all. There is no error message, just the usual "The following users were sucessfully imported:" with no usernames following. I can still add users manually, but the batch import doesn't work at all...

Any ideas why?

Cheers
Matthias
JR Schmidt
Moderator
Username: Schmidt

Post Number: 510
Registered: 11-2006
Posted on Tuesday, July 12, 2016 - 10:45 am:   

Very odd.

Try importing a entirely new ("test") user from the batch import. Perhaps the prior batch of users did not actually get deleted, etc. Also double check the format of the CSV file.
Matthias Lein
Unregistered guest
Posted on Tuesday, July 12, 2016 - 6:46 pm:   

Hi JR

Very odd indeed... I have solved the problem though. When I edited the csv file with Excel it changed the encoding to something WebMO wouldn't read. select-all, copy & paste into a new text document fixed the issue.

Cheers
Matthias
Bob Gotwals
Unregistered guest
Posted on Tuesday, August 30, 2016 - 9:59 am:   

I have a properly configured .csv file, and the batch import does not work. I'm getting a message that says users were successfully imported, but they don't show up in the users list.
John Keller
Unregistered guest
Posted on Monday, November 07, 2016 - 1:11 pm:   

I cannot import a list of users as described in the Help files. I have tried 5 Windows text file formats and a text file written by CentOS vi. All give the same error message as shown in the attached .png file. What I am doing wrong?Screenshot of WebMO User Manager and Vi window
JR Schmidt
Moderator
Username: Schmidt

Post Number: 540
Registered: 11-2006
Posted on Monday, November 07, 2016 - 1:31 pm:   

John,

There is an issue with spaces here that was introduced when I tried to fix another problem (related to Mac OS line endings in Excel-generated CSV files!). For now, eliminate the space in the names. A real fix will be in the next release.
Kevin Range
Unregistered guest
Posted on Sunday, February 05, 2017 - 3:12 pm:   

Argh. I just got bit by this too.
danielberger
Unregistered guest
Posted on Friday, August 16, 2019 - 2:54 pm:   

I am not able to convince WebMO to load the attached UTF-8 text file. It has no spaces in it at all, and has comma-separated values.

I get the error message "A 'username', 'group' and 'password' field are required".

I have tried fiddling with capitalization.
text/plainUser file that doesn't work
WebMOusers.txt (0.6 k)
JR Schmidt
Moderator
Username: Schmidt

Post Number: 645
Registered: 11-2006
Posted on Monday, August 19, 2019 - 10:52 am:   

Daniel,

The issue is that the UTF-8 file you attached uses a byteorder mark at the beginning of the file. This is unusual. ("The Unicode Standard permits the BOM in UTF-8, but does not require or recommend its use.") Re-encoding the file without a byteorder mark (and thus removing the binary at the beginning of the file) makes it work fine.
Anonymous
 
Posted on Tuesday, August 20, 2019 - 3:49 pm:   

In WebMO 19, multiple-user import files can contain spaces in the FullName field.

Add Your Message Here
Post:
Username: Posting Information:
This is a public posting area. Enter your username and password if you have an account. Otherwise, enter your full name as your username and leave the password blank. Your e-mail address is optional.
Password:
E-mail:
Options: Post as "Anonymous"
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Last Week | Tree View | Search | Help/Instructions | Program Credits Administration