Upgrading issues

Post Reply
skirkby
Posts: 2
Joined: Mon Jun 29, 2020 3:59 pm
Full Name: Scott Kirkby
Organization: East Tennessee State University

Upgrading issues

Post by skirkby »

After upgrading to 20.0.011e, all of my interfaces generate the same type of error:

Cannot execute /opt/nwchem/bin/nwchem: No such file or directory

Cannot execute /opt/gamess/ddikick.x: No such file or directory

sh: /opt/mopac/MOPAC2016.exe: No such file or directory


The files exist and could be run before the upgrade.

schmidt
Posts: 13
Joined: Sat May 30, 2020 3:00 pm
Full Name: JR Schmidt
Organization: WebMO, LLC

Re: Upgrading issues

Post by schmidt »

Scott,
A few questions:

How recently had you run WebMO prior to upgrading?
Are you certain that your installation working / running jobs immediately prior to upgrading?
What OS are you running?
Any recent OS upgrades, etc?

You might also look in the WebMO error log (<webmo_user>/errors) for additional information.

skirkby
Posts: 2
Joined: Mon Jun 29, 2020 3:59 pm
Full Name: Scott Kirkby
Organization: East Tennessee State University

Re: Upgrading issues

Post by skirkby »

WebMO was running and the interfaces were all working until just a few minutes before starting the backup before the upgrade.

The interfaces were working because I tested them to make sure.

The OS is CentOS 7.8 (fully updated with yum the day before).

I rolled backup the upgrade by using the backup to restore everything to before the tar file was unpacked. Everything worked normally. I then followed the upgrade procedure again. This time MOPAC and Gamess worked, but NWChem is still not working.

There are no errors in the error file from several weeks before upgrade process. The only entries for NWChem are from the upgrade to 6.8.1 from 6.8 in that 6.8.1 is not a numeral.

The error is still:

Cannot execute /opt/nwchem/bin/nwchem: No such file or directory

but ls -l /opt/nwchem/bin/nwchem

gives

-rwxr-xr-x 1 root root 88741112 Jan 16 2019 /opt/nwchem/bin/nwchem

so the file is definitely there and I can successfully run NWChem from outside WebMO.

Any suggestions?

Is it possible to do a fresh clean install and copy the database into the fresh install so that the calculation results are still accessible?

schmidt
Posts: 13
Joined: Sat May 30, 2020 3:00 pm
Full Name: JR Schmidt
Organization: WebMO, LLC

Re: Upgrading issues

Post by schmidt »

A clean install is definitely possible. You should be able to simple replace the 'user/job' directory. That said, I cannot understand why the upgrade would cause a problem. You might check the 'run_log' file, stored in the job directory, for a detailed description of what is going on.

One last thought: You are using remote servers?? Are you sure that the job is executing on the LOCAL server vs. the remote server? Do all remote servers have NWChem installed?

polik
Posts: 8
Joined: Fri May 29, 2020 6:20 pm
Full Name: Will Polik
Organization: WebMO LLC

Re: Upgrading issues

Post by polik »

If using remote servers, be sure to also upgrade those according to the Upgrading WebMO instructions:
Remote Servers: If you are upgrading WebMO Pro/Enterprise and have configured any remote servers, these remote servers must also be upgraded:
  • Login to WebMO as the admin user
  • From the Remote Server Manager, choose the edit servers tab and click the Upgrade icon for each server
  • Logout of WebMO as the admin user

Post Reply