Error after editing the computational engine subdirectory

Post Reply
farid
Posts: 5
Joined: Sun May 16, 2021 2:11 pm
Full Name: Mohd Farid Ismail
Organization: Universiti Putra Malaysia
Subdiscipline: Computational Chemistry

Error after editing the computational engine subdirectory

Post by farid »

I installed the WebMO Basic, and setup the interface to the PSI4 computational engines. Everything was running fine. Then I reinstalled PSI4, and into a different folder. So, I decided to edit the interface. After the interface was edited, I can't run PSI4 job anymore. The error I get every time is,

Key Error: "Too many unknown argument, ['-p', '5', input.inp', 'output.out']". Can anyone point out what the problem is?

webmo
Site Admin
Posts: 11
Joined: Sun Apr 05, 2020 7:16 pm
Full Name: WebMO Forum Administrator
Organization: WebMO LLC

Re: Error after editing the computational engine subdirectory

Post by webmo »

Please do not manually edit the interface files. Use the "Interface Manager" under admin.

Please just check the syntax of the psi.int file. It is simply key/value pairs separated with an "=" sign. The values are strings that must be quoted.

farid
Posts: 5
Joined: Sun May 16, 2021 2:11 pm
Full Name: Mohd Farid Ismail
Organization: Universiti Putra Malaysia
Subdiscipline: Computational Chemistry

Re: Error after editing the computational engine subdirectory

Post by farid »

To be clear, I did edit the interface via the interface manager under the admin page. I only changed the path to psi4, and hit submit. Then return.

I don't find anything wrong with the psi.int file. All the values after the = sign are all quoted.
psi4webmo.png
psi4webmo.png (28.72 KiB) Viewed 15782 times

farid
Posts: 5
Joined: Sun May 16, 2021 2:11 pm
Full Name: Mohd Farid Ismail
Organization: Universiti Putra Malaysia
Subdiscipline: Computational Chemistry

Re: Error after editing the computational engine subdirectory

Post by farid »

To add to this, the second value in the quoted arguments, i.e. '5', seems to corresponds to the job number. If my job number is 13, then the error I get is

Key Error: "Too many unknown argument, ['-p', '13', input.inp', 'output.out']".

It's as is WebMO is passing the job to psi4 with the argument psi4 -p 13 input.inp output.out.

Post Reply