Issues with WebMO 17 after OS upgrade to Rocky Linux 9

Post Reply
connerms
Posts: 5
Joined: Thu Jun 11, 2020 4:16 pm
Full Name: Mike C
Organization: Grinnell College

Issues with WebMO 17 after OS upgrade to Rocky Linux 9

Post by connerms »

I have WebMO 17 installed on a cluster. The cluster was upgraded from CentOS 7 to Rocky Linux 9. I have followed the docs to ensure the Apache config for WebMO is correct but when I browse to WebMO (or any cgi script) I get a 500 'Internal Server Error' message "The server encountered an internal error or misconfiguration and was unable to complete your request...."

Here is the contents of my /etc/httpd/conf.d/userdir.conf file:

Code: Select all

<IfModule mod_userdir.c>
    UserDir public_html
</IfModule>

<Directory "/home/*/public_html">
    AllowOverride FileInfo AuthConfig Limit
    Options MultiViews SymLinksIfOwnerMatch IncludesNoExec
    Require method GET POST OPTIONS PUT DELETE PATCH
    AddHandler cgi-script .cgi
</Directory>

<Directory "/home/*/public_html/cgi-bin/webmo">
    AddHandler cgi-script .cgi
    Options +ExecCGI
</Directory>
RedirectMatch ^/webmo(()|/)$ /~webmo/cgi-bin/webmo/login.cgi
The mod_cgid module is loaded:

Code: Select all

# httpd -M | grep cgid
 cgid_module (shared)
I've double checked all the permissions on the webmo home directory.

The only error recorded in the apache error log when I load the page is:

Code: Select all

[cgid:debug] [pid 151361:tid 151361] mod_cgid.c(854): using passed fd 13 as stderr
I haven't uncovered any helpful information and don't know where else to turn to look for some. Any help is greatly appreciated!

schmidt
Posts: 80
Joined: Sat May 30, 2020 3:00 pm
Full Name: JR Schmidt
Organization: WebMO, LLC

Re: Issues with WebMO 17 after OS upgrade to Rocky Linux 9

Post by schmidt »

I'm not convinced that the error you are seeing in the log is related to the script. Is it repeated each time you try and run a script, or only once?

If it is really EACH time, it appears to be an internal error in Apache itself when trying to run scripts via modcgi. This would be surprisingly.

Make sure to check all error_log, ssl_error_log, and suexec log files, as errors are logged to varying locations depending on the details of the setup.

As you note, since this appears with ALL scripts, it is not a WebMO issue per se. My guess is that once you find the right log file, the error will be more clearly explained.

connerms
Posts: 5
Joined: Thu Jun 11, 2020 4:16 pm
Full Name: Mike C
Organization: Grinnell College

Re: Issues with WebMO 17 after OS upgrade to Rocky Linux 9

Post by connerms »

The error is repeated EACH time I load the URL (to run the script) in the browser.

That is the only error that appears in any logs (apache or otherwise) when the script is run.

I've discovered that I cannot run ANY perl scripts from the /home/webmo/public_html/cgi-bin/webmo directory - even one that I placed myself that is just a very simple script:

Code: Select all

#!/usr/bin/perl
print "Content-type: text/html\n\n";
print "Hi there.";
I also get the same 500 error if I place that script in another user's /home/user/public_html/cgi-bin/ directory. So I'm less convinced that this issue is specific to WebMO, but rather is an issue with cgi-bin scripts in userdirs in my environment. The same script above works when placed in /var/www/cgi-bin/.

For the purposes of ruling out an issue with WebMO specifically and to confirm that I'm not trying to do something impossible, can anyone confirm that WebMO 17 will run on Rocky Linux 9 with Apache 2.4.53?

Post Reply